NTP Server on Windows - SNTP

Next...



Download Net Time http://www.timesynctool.com/ lalu setelah itu, setting tambahan dibawah ini:
  1. Masuk ke services bisa melalui task manager, atau klik kanan manage my computer, atau dari run command box
  2. Set Automatic Windows Time service dan start service tersebut
  3. Lalu setting time nya di komputer tersebut, nanti perangkat yang ponting ke windows ini akan otomatis update waktu jika tidak sama

Perangkat yang baru saya coba hanya menggunakan mikrotik, maklum mabok mikrotik

/system ntp client
set enabled=yes primary-ntp=IP_KOMPUTER_WINDOWS



Ref https://www.interfacett.com/blogs/creating-standalone-ntp-server-windows/

Related Posts:

Restrict Access and Secure Mikrotik

Next...

Setelah banyak kejadian bahwa mikrotik terkena hack di beberapa kasus, maka kita wajib melakukan preventif action untuk menghindari mikroitk jebol, terutama pada kasus port web yang sudah banyak kena bugs

Yang pertama menutup port yang tidak digunakan, dan membuka port yang digunakan istilah nya Negatif Rule dan kita set port tidak menggunakan default nya seperti ssh dan telnet, khusus port www atau web sebaiknya ditutup saja karna sudah ada bugsnya, kalau sudah ada update bugs nya bisa dibuka kembali

/ip service
set telnet port=2312
set ftp disabled=yes
set www disabled=yes
set ssh port=2212
set api disabled=yes
set api-ssl disabled=yes

Lalu kita set restrict akses secara umum, dan mengizinkan beberapa ip saja

/ip firewall filter
add action=drop chain=input comment=\
    "AKSES ROUTER HANYA DARI IP VPN" dst-port=8291,2212,2312 \
    protocol=tcp src-address-list=!AKSES
/ip firewall address-list
add address=103.xxx.0/24 list=AKSES
add address=102.xxx.0/24 list=AKSES
add address=10.16.0.0/16 list=AKSES
add address=10.18.0.0/16 list=AKSES
add address=223.xxx.0/24 list=AKSES

Arigatou :D

Related Posts:

Syslog Server by Splunk - Additional Transparent Proxy



Next..

Syslog Server digunakan untuk mengumpulkan log-log perangkat secara realtime, dalam kasus ini menggunakan mikrotik sebagai perangkat nya dan menggunakan splunk sebagai aplikasinya

Splunk versi free nya hanya dibatasi 500MB /hari selebihnya berbayar, jadi untuk set free silahkan download seperti biasa
Ref: https://www.splunk.com/en_us/download/splunk-light.html

Lalu setelah install jangan lupa set free license untuk tidak terkena free trial 30 hari saja
Settings->licensing->Change license group->Free licnse->Save

Yang free tidak ada sistem auth jadi kalau login langsung masuk ke dashboard, jadi biasanya saya restrick menggunakan firewall di mikrotik hanya ip X yang bisa akses ke port 8000

/ip firewall filter
add action=drop chain=forward dst-address=IP_SERVER dst-port=8000 \
    protocol=tcp src-address=!IP_SAYA/IP_VPN

Install seperti biasa disini saya menggunakan windows, jadi hanya next next saja, jangan lupa masukkan password ketika instalasi karna untuk login pertama kali menggunakan password tersebut
saya mencoba menggunakan default password splunk admin dan changeme namun tidak bisa. Jadi jangan sampai lupa

Setelah proses instalasi ada beberapa add-on yang bagus untuk diinstall
Mikrotik https://splunkbase.splunk.com/app/3845/
Mikrotik https://splunkbase.splunk.com/app/483/
Dataset https://splunkbase.splunk.com/app/3245/
Netflow https://splunkbase.splunk.com/app/1658/

Cara install add-on nya:
-> download app splunk from these ex
>> splunk-datasets-add-on_10.tgz
-> install app to this http://server-address/en-US/manager/launcher/apps/local
-> install app from file

Penggunaannya bervariasi, ada yang berguna pada saat melakukan search, atau report, atau pada dashboard dll, agak rumit juga tapi kalau sudah terbiasa akan mudah

Ok Next...

Setelah melakukan instalasi Splunk dan Add on nya, maka hal yang perlu dilakukan adalah melakukan allow untuk port splunk dan syslog terkait seperti port 8000, 514, atau port yang kita identifikasikan sendiri ketika mengirimkan log ke splunk server
Kalau saya karna tidak mau repot, saya lakukan disable firewall di windows, namun resiko ditanggung sendiri

Untuk splunk sendiri bisa dibuka aplikasi nya menggunakan browser
http://IP_SERVER:8000

Setelah itu login, dan kita siapkan server splunk untuk listen trafik yang akan masuk
Setting->Datainputs->Add new (behind the UDP)->Port 514->Next->Sourcetype type syslog and select syslog->Next-Submit
Atau bisa kesini
http://103.xxx.2:8000/en-US/manager/search/data/inputs/udp
http://103.xxx.2:8000/en-US/manager/search/adddata/selectsource?input_mode=1&input_type=udp
Berikut data biasanya:
- UDP
- Port 514
- Sourcetype=Cisco atau bisa buat sendiri sesuai kategori perangkat juga bisa
- Index=main atau bisa buat sendiri sesuai kategori client juga bisa

Dari sini berarti splunk berstatus listen dan siap menerima data dari perangkat yang akan mengirimkan log

Lanjut kita setting mikrotik nya. Kalau saya seperti ini settingannya

/system logging action
add bsd-syslog=yes name=syslog remote=IP_SERVER \
    remote-port=514 src-address=IP_PERANGKAT \
    syslog-facility=syslog target=remote
/system logging
add action=syslog topics=info
add action=syslog topics=warning
add action=syslog topics=error
add action=syslog topics=critical

Kalau sudah coba lakukan perubahan setting di Mikrotik dan cek log di mikrotik, nanti log tersebut akan dikirim ke splunk, sekarang kita coba lihat di splunk nya ke bagian search
http://103.xxx.2:8000/en-US/app/search/search lalu masukkan kata kuncinya
* (artinya semua log akan terlihat)
index=main (hanya yang index main saja yang terlihat)

Contoh search di splunk
source="udp:514" index="client" sourcetype="Mikrotik" (NOT "dhcp") (NOT "dhcp1")
index=lapan (host="bgp" OR host="vpn") (NOT "No route to host") (NOT "RemoteAddress") (NOT "TCP connection established") (NOT "HoldTimer") (NOT "Connection opened")

Kalau mau delete tinggal tambahkan "| delete" di akhir search, tp pastikan kalau data tersebut benar-benar kita ingin delete dengan check search dulu contoh
source="udp:51403" index="client" sourcetype="Mikrotik" (NOT "dhcp") (NOT "dhcp1") | delete

Kalau mau buat Chart di dashboard bisa count by host atau date
* | stats count by host
* "logged" | chart count by host
* | convert timeformat="%Y-%m-%d" ctime(_time) AS date | stats count by date

Untuk membuat dashboard seperti gambar di artikel ini, bisa ke sini
http://103.51.131.2:8000/en-US/app/search/dashboards

Lalu create saja, semua dashboard di splunk adalah kombinasi dari command-command search yang diatas dan tinggal pilih visualizationnya menggunakan chart apa saja, mirip seperti mysql, ini yang membuat saya lucu ketika pertama kali belajar splunk, tapi sangat memuaskan meskipun pada mode free :D Seru pokoknya
Contoh command dashboard
- index="client" (NOT "No route to host") (NOT "RemoteAddress") (NOT "dhcp1") (NOT "dhcp") | stats count by host
- * "logged" | chart count by host
- * "login failure" | convert timeformat="%Y-%m-%d" ctime(_time) AS date | stats count by date
- index="traffic"
- index=client (host="bgp" OR host="vpn") (NOT "No route to host") (NOT "RemoteAddress") (NOT "TCP connection established")
- sourcetype="Data Traffic" | chart  count(_raw) by date
- sourcetype="Data Traffic"   field15="(after" | chart  count(_raw) by domain
- index=client(NOT host="BGP") (NOT host="VPN") (NOT "dhcp1")

Yang agak rumit menggunakan dataset dan membuat table serta meng-extract field menggunakan regex expression :D

Kalau mau nge-log All Traffic seperti di torch
Send Log Torch from mikrotik https://forum.mikrotik.com/viewtopic.php?t=63223
/ip firewall mangle
add action=log chain=forward
/system logging action
add bsd-syslog=yes name=logging remote=103.xxx.2 remote-port=51404 src-address=\
    103.xxx.5 syslog-facility=syslog target=remote
/system logging
add action=logging topics=info
add action=logging topics=firewall

Trap data in splunk server
-> http://server-address/en-US/manager/search/data/inputs/udp
-> New Local UDP
-> port 51404 -> index "traffic"
-> Check data received index="traffic"
-> Click dataset New Table

Terakhir kalau mau trap source address dan destination web menggunakan web-proxy fiture di mikrotik (transparent proxy) maka bisa seperti dibawah ini, tapi hanya www atau port 80 saja yang terlog, karna https atau 443 dia ter-encrypt jadi tidak ter log

Settingannya sama di splunk nya, tinggal create dan listen saja, misal di port 51404

Di mikrotiknya tinggal set firewall, logging
/ip firewall nat
add action=redirect chain=dstnat comment="TES LOG" disabled=yes dst-port=80 protocol=tcp \
    to-ports=8080

/system logging action
add bsd-syslog=yes name=logging remote=103.XXX.2 remote-port=51404 src-address=\
    103XXX.1 syslog-facility=syslog target=remote
/system logging
add action=logging topics=web-proxy,!debug

Lalu di ip -> web-proxy, dicentang enable saja... Otomatis semua data transparent nya ke log di splunk :D


^_^

Related Posts:

Telegram Create BOT

Next...


- Buat Bot Telegram
Ref https://www.sohamkamani.com/blog/2016/09/21/making-a-telegram-bot/
https://web.telegram.org/#/im?p=@BotFather
# /newbot
# PT. Huka Huka
# Huka_Huka_Bot
# Use this token to access the HTTP API:
# 574xx411:AAGxxxxxxnGlc7U8OY2Rq4gu3c24Q0OY
>> The result you will get this token >> token: 574xx411:AAGxxxxxxnGlc7U8OY2Rq4gu3c24Q0OY

- Buat Group atau gunakan Group Existing
>> via Panel >> New Group

- Invite Bot ke dalam group (Admin Group)
>> via Panel >> Invite >> @Huka_Huka_Bot

- Mention Bot nya
# /hi @Huka_Huka_Bot

- Buka JSON Bot
https://api.telegram.org/bot<TOKEN_BOT>/getUpdates
https://api.telegram.org/bot574xx411:AAGxxxxxxnGlc7U8OY2Rq4gu3c24Q0OY/getUpdates

Keluar data:
{"ok":true,"result":[{"update_id":113528262,
"message":{"message_id":4,"from":{"id":33333333,"is_bot":false,"first_name":"Nazar","last_name":"Yono"},"chat":{"id":-444444,"title":"IP CORE","type":"group","all_members_are_administrators":true},"date":1527608038,"text":"/hi @Huka_Huka_Bot","entities":[{"offset":0,"length":3,"type":"bot_command"},{"offset":4,"length":12,"type":"mention"}]}}]}

>> The result you will get this id of your bot >> -444444

- Send text
https://api.telegram.org/bot574xx411:AAGxxxxxxnGlc7U8OY2Rq4gu3c24Q0OY/sendMessage?chat_id=-444444&text=Tes1


- Delete Bot
Karna membuatnya via https://web.telegram.org/#/im?p=@BotFather maka delete dari sini juga
# /deletebot
# klik @Huka_Huka_Bot
# Yes, I am totally sure.


Related Posts:

BGP Full Router dan Default Route

Next..

Full route adalah metode router distribusi meneruskan prefix yang diterima dari upstream kepada downstreamnya dengan filter out ke downstreamnya permit

Default route adalah metode router distribusi hanya memberikan prefix 0.0.0.0 kepada downstreamnya dengan filter out ke downstreamnya deny biasanya disebut dengan default origin

Contoh Default Route
==> default-originate
==> filter out deny
# sh run
 neighbor 103.23.34.74 remote-as 8888
 neighbor 103.23.34.74 description VENUS
 neighbor 103.23.34.74 weight 1500
 neighbor 103.23.34.74 route-reflector-client
 neighbor 103.23.34.74 default-originate
 neighbor 103.23.34.74 soft-reconfiguration inbound
 neighbor 103.23.34.74 filter-list VENUS-IN in
 neighbor 103.23.34.74 filter-list VENUS-OUT out
# sh ip as-path-access-list VENUS-OUT                                      
AS path access list VENUS-OUT
    deny .*
Contoh Full Route
==> 
 neighbor 103.23.34.78 remote-as 8888
 neighbor 103.23.34.78 description IBGP WERKUDORO-DPS-VIA-HYPER
 neighbor 103.23.34.78 weight 1500
 neighbor 103.23.34.78 route-reflector-client
 neighbor 103.23.34.78 soft-reconfiguration inbound
 neighbor 103.23.34.78 prefix-list WERKUDORO in
 neighbor 103.23.34.78 filter-list WERKUDORO-IN in
 neighbor 103.23.34.78 filter-list WERKUDORO-OUT out


router bgp 8888
no neighbor 103.23.34.76 default-originate
exit
no ip as-path-access-list  MERCURIUS-OUT deny .*
ip as-path-access-list MERCURIUS-OUT permit .*
clear ip bgp 103.23.34.76 soft in

router bgp 8888
no neighbor 103.23.34.80 default-originate
exit
no ip as-path access-list BUMI-OUT deny .*
ip as-path access-list BUMI-OUT permit .*
clear ip bgp 103.23.34.80 soft in

router bgp 8888
no neighbor 103.23.34.93 default-originate
exit
no ip as-path access-list NEPTUNUS-OUT deny .*
ip as-path access-list NEPTUNUS-OUT permit .*
clear ip bgp 103.23.34.93 soft in



Related Posts:

BGP IPv6 Peer

Next


clear bgp ipv6 neighbor
# clear bgp ipv6 2401:2400:10:9::2




Related Posts:

Full Mesh Topology By Route Reflector (iBGP-OSPF)

Next...

Topology nya sederhana

Jadi saya sebelumnya mau membuat full mesh topology dengan topology seperti ini, jadi kalau full mesh berarti tiap-tiap router akan memiliki 2 peer yaitu
PE-JKT <> RR
PE-JKT <> PE-BALI

PE-BALI<>RR
PE-BALI<>PE-JKT

RR<>PE-JKT
RR<>PE-BALI

Namun kita akan menggunakan route reflector, dengan RR (Route Reflector) maka peering akan semakin sedikit karna kita hanya perlu melakukan peer ke RR nya saja, syarat dari topology ini adalah:
- Semua router harus bisa terhubung satu sama lain bisa menggunakan IGP (OSPF/EIGRP/RIP/Static Route/Etc) atau juga diganti topology-nya menjadi star menggunakan switch/hub dimana nanti IP yang digunakan untuk peer harus 1 network misal: PE-JKT 10.10.10.1, PE-BALI 10.10.10.2, RR 10.10.10.3 semuanya /29
- Menambahkan neighbor add_peer route-reflector-client pada router RR nya

Simple kan :D

Karna disini saya menggunakan OSPF berikut settingan OSPF nya di tiap-tiap router, dimulai dari
RR dan baru ke Client RR nya

RR#sh run | s FastEthernet0/0
interface FastEthernet0/0
 ip address 10.10.0.1 255.255.255.252
 ip ospf network point-to-point
 ip ospf 100 area 0
 duplex auto
 speed auto
RR#sh run | s FastEthernet0/1
interface FastEthernet0/1
 ip address 10.10.0.5 255.255.255.252
 ip ospf network point-to-point
 ip ospf 100 area 0
 duplex auto
 speed auto
RR#sh run | s Loopback0
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 100 area 0
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.3 update-source Loopback0
RR#sh run | s router ospf
router ospf 100
 log-adjacency-changes
RR#

PE-JKT#sh run | s FastEthernet0/0
interface FastEthernet0/0
 ip address 10.10.0.2 255.255.255.252
 ip ospf network point-to-point
 ip ospf 100 area 0
 duplex auto
 speed auto
PE-JKT#

PE-BALI#sh run | s FastEthernet0/0
interface FastEthernet0/0
 ip address 10.10.0.6 255.255.255.252
 ip ospf network point-to-point
 ip ospf 100 area 0
 duplex auto
 speed auto
PE-BALI#

Next adalah membuat peering, karna dengan OSPF diatas (Proses ID 100) maka pastinya antara IP Loopback akan bisa terhubung, dan disini kita melakukan peering menggunakan IP Loopback masing-masing router

RR#sh run | s router bgp
router bgp 100
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 10.0.0.2 remote-as 100
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 route-reflector-client
 neighbor 10.0.0.3 remote-as 100
 neighbor 10.0.0.3 update-source Loopback0
 neighbor 10.0.0.3 route-reflector-client
 no auto-summary
RR#

PE-JKT#sh run | s router bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.20.10.0 mask 255.255.255.252
 neighbor 10.0.0.1 remote-as 100
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 soft-reconfiguration inbound
 no auto-summary
PE-JKT#

PE-BALI#sh run | s router bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.20.20.0 mask 255.255.255.252
 neighbor 10.0.0.1 remote-as 100
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 soft-reconfiguration inbound
 no auto-summary
PE-BALI#

Kalau sudah kita buat peeringnya maka status nya akan seperti ini
RR#sh ip bgp sum
BGP router identifier 10.0.0.1, local AS number 100
BGP table version is 3, main routing table version 3
2 network entries using 258 bytes of memory
2 path entries using 104 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 610 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.2        4   100      14      15        3    0    0 00:10:22        1
10.0.0.3        4   100      14      15        3    0    0 00:10:20        1
RR#



Have fun with BGP ^_^

Related Posts:

External BGP with Cisco


Harus tau apa itu External BGP dan Internal BGP

Saya juga masih belum paham teorinya, tapi seperti nya Lab di bawah ini masuk ke dalam kategori External BGP karna setiap peer lawannya menggunakan AS Number yang berbeda, dan disini masih dasar sekali karna disini tidak dilakukan manipulasi prefix (prefix filter)


>> Lanjut lagi, pertama adalah settingan interface adalah sebagai berikut:
Router Core (R2)
interface FastEthernet0/0
 ip address 182.23.172.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 182.23.173.1 255.255.255.0
 duplex auto
 speed auto
!

Router Dist sisi Kiri (R1) 
interface FastEthernet0/0
 ip address 182.23.172.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 103.16.223.1 255.255.255.0
 duplex auto
 speed auto
!
Router Dist sisi Kanan (R3) 
interface FastEthernet0/0
 ip address 182.23.173.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 103.51.131.1 255.255.255.0
 duplex auto
 speed auto
!

Router Cust sisi Kiri (R4)
interface FastEthernet0/0
 ip address 103.16.223.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 103.28.21.1 255.255.255.0
 duplex auto
 speed auto
!
Router Cust sisi Kanan (R5)
interface FastEthernet0/0
 ip address 103.51.131.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 103.31.157.1 255.255.255.0
 duplex auto
 speed auto
!

Untuk konfigurasi interface sama seperti biasanya tidak ada yang berbeda, kita tidak menggunakan IP Loopback dalam Lab kali ini

>>> Next Setting BGP dari Router Core ke Router Dist
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 182.23.172.0 mask 255.255.255.0
 network 182.23.173.0 mask 255.255.255.0
 neighbor 182.23.172.2 remote-as 5001
 neighbor 182.23.172.2 update-source FastEthernet0/0
 neighbor 182.23.172.2 soft-reconfiguration inbound
 neighbor 182.23.173.2 remote-as 5002
 neighbor 182.23.173.2 update-source FastEthernet0/1
 neighbor 182.23.173.2 soft-reconfiguration inbound
 no auto-summary
!

>>> Dan dari sisi Router Dist nya ke router core
Router Dist R1, disini kita meng-advertise IP 103.16.223.0/24 ke Router Core
router bgp 5001
 no synchronization
 bgp log-neighbor-changes
 network 103.16.223.0 mask 255.255.255.0
 neighbor 182.23.172.1 remote-as 100
 neighbor 182.23.172.1 update-source FastEthernet0/0
 neighbor 182.23.172.1 soft-reconfiguration inbound
 no auto-summary
!
Router Dist R3, disini kita meng-advertise IP 103.51.131.0/24 ke Router Core
router bgp 5002
 no synchronization
 bgp log-neighbor-changes
 network 103.51.131.0 mask 255.255.255.0
 neighbor 182.23.173.1 remote-as 100
 neighbor 182.23.173.1 update-source FastEthernet0/0
 neighbor 182.23.173.1 soft-reconfiguration inbound
 no auto-summary
!

>>> Lalu kita buat peer dari Router Dist ke Router Cust menggunakan IP yang sudah di advertise sebelumnya ke Router Core
Router Dist (R1)
router bgp 5001
neighbor 103.16.223.2 remote-as 7778
 neighbor 103.16.223.2 update-source FastEthernet0/1
 neighbor 103.16.223.2 soft-reconfiguration inbound
Router Dist (R3)
router bgp 5002
neighbor 103.51.131.2 remote-as 6668
 neighbor 103.51.131.2 update-source FastEthernet0/1
 neighbor 103.51.131.2 soft-reconfiguration inbound

>>> Lalu kita buat Peer di Router Cust nya, jangan lupa untuk advertise IP dibawahnya
Router Cust Kiri (R4)
router bgp 7778
 no synchronization
 bgp log-neighbor-changes
 network 103.28.21.0 mask 255.255.255.0
 neighbor 103.16.223.1 remote-as 5001
 neighbor 103.16.223.1 update-source FastEthernet0/0
 neighbor 103.16.223.1 soft-reconfiguration inbound
 no auto-summary
!
Router Cust Kanan (R5)
router bgp 6668
 no synchronization
 bgp log-neighbor-changes
 network 103.31.157.0 mask 255.255.255.0
 neighbor 103.51.131.1 remote-as 5002
 neighbor 103.51.131.1 update-source FastEthernet0/0
 neighbor 103.51.131.1 soft-reconfiguration inbound
 no auto-summary
!

>> Sekarang kita lihat peer dari Router Cust hingga ke Router Core
RO-CUST-R4#sh ip bgp sum | beg Nei
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
103.16.223.1    4  5001      27      23        8    0    0 00:19:16        5

>>  Melihat prefix yang Router Cust lemparkan / advertise-kan ke atas (Router Dist)
RO-CUST-R4#sh ip bgp nei 103.16.223.1 advertised-routes
BGP table version is 8, local router ID is 103.28.21.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 103.28.21.0/24   0.0.0.0                  0         32768 i

Total number of prefixes 1

>> Melihat prefix yang diterima dari router atas nya (Ro Dist), disini kita menggunakan full route, tidak menggunakan default originate, jadi prefix nya diterima semua yang ada pada routing table bgp nya
RO-CUST-R4#sh ip bgp nei 103.16.223.1 received-routes
BGP table version is 8, local router ID is 103.28.21.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 103.16.223.0/24  103.16.223.1             0             0 5001 i
*> 103.31.157.0/24  103.16.223.1                           0 5001 100 5002 6668 i
*> 103.51.131.0/24  103.16.223.1                           0 5001 100 5002 i
*> 182.23.172.0/24  103.16.223.1                           0 5001 100 i
*> 182.23.173.0/24  103.16.223.1                           0 5001 100 i

Total number of prefixes 5

>> Cek route nya, sama dengan received-routes biasanya
RO-CUST-R4#sh ip bgp nei 103.16.223.1 routes
BGP table version is 8, local router ID is 103.28.21.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 103.16.223.0/24  103.16.223.1             0             0 5001 i
*> 103.31.157.0/24  103.16.223.1                           0 5001 100 5002 6668 i
*> 103.51.131.0/24  103.16.223.1                           0 5001 100 5002 i
*> 182.23.172.0/24  103.16.223.1                           0 5001 100 i
*> 182.23.173.0/24  103.16.223.1                           0 5001 100 i

Total number of prefixes 5

Berikut hasil akhir trace nya



Berikut perbedaan dari Router Dist terkait prefix BGP nya
RO-DIST-R1#sh ip bgp sum | beg Nei
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
103.16.223.2    4  7778      32      36        8    0    0 00:28:59        1
182.23.172.1    4   100      37      37        8    0    0 00:29:01        4

RO-DIST-R1#sh ip bgp nei 103.16.223.2 received-routes
BGP table version is 8, local router ID is 182.23.172.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 103.28.21.0/24   103.16.223.2             0             0 7778 i

Total number of prefixes 1

RO-DIST-R1#sh ip bgp nei 103.16.223.2 advertised-routes
BGP table version is 8, local router ID is 182.23.172.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 103.16.223.0/24  0.0.0.0                  0         32768 i
*> 103.28.21.0/24   103.16.223.2             0             0 7778 i
*> 103.31.157.0/24  182.23.172.1                           0 100 5002 6668 i
*> 103.51.131.0/24  182.23.172.1                           0 100 5002 i
r> 182.23.172.0/24  182.23.172.1             0             0 100 i
*> 182.23.173.0/24  182.23.172.1             0             0 100 i

Total number of prefixes 6
RO-DIST-01#sh ip bgp nei 182.23.172.1 advertised-routes
BGP table version is 8, local router ID is 182.23.172.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 103.16.223.0/24  0.0.0.0                  0         32768 i
*> 103.28.21.0/24   103.16.223.2             0             0 7778 i
*> 103.31.157.0/24  182.23.172.1                           0 100 5002 6668 i
*> 103.51.131.0/24  182.23.172.1                           0 100 5002 i
r> 182.23.172.0/24  182.23.172.1             0             0 100 i
*> 182.23.173.0/24  182.23.172.1             0             0 100 i

Total number of prefixes 6

RO-DIST-R1#sh ip bgp nei 182.23.172.1 received-routes
BGP table version is 8, local router ID is 182.23.172.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 103.31.157.0/24  182.23.172.1                           0 100 5002 6668 i
*> 103.51.131.0/24  182.23.172.1                           0 100 5002 i
r> 182.23.172.0/24  182.23.172.1             0             0 100 i
*> 182.23.173.0/24  182.23.172.1             0             0 100 i

Total number of prefixes 4

Have fun with BGP ^_^


Keterangan

 neighbor 182.23.173.2 remote-as 5002
>> Membuat Peer BGP

 neighbor 182.23.173.2 update-source FastEthernet0/1
>> Mendefinisikan source interface

 neighbor 182.23.173.2 soft-reconfiguration inbound
>> Supaya peer lawan dapat melihat prefix yang diterima/dilempar, atau supaya auto refresh (mungkin ahahaha)

Related Posts:

Redirect DNS External to DNS Internal - Mikrotik


Case nya adalah ketika user dibawah router kita menggunakan DNS luar dan akan dengan mudah mengakses beberapa web yang dilarang oleh perusahaan

Jadi port DNS yaitu 53 kita dst-nat kan menuju ip DNS Filter yang akan kita gunakan

Sebagai informasi DNS port 53 itu berada pada 2 sisi protocol antara UDP dan TCP jadi untuk lebih maksimal, kita lakukan dst-nat untuk kedua protocol tersebut




Related Posts:

Set MTU Mikrotik - Jumbo Frame

Next...
Untuk set MTU pada interface mikrotik, hanya butuh command dibawah ini, namun kadang interface menjadi down namun kadang langsung up, dan tiap-tiap perangkat berbeda maksimum MTU nya, meskit kita set misal 9000, kalau maksimum nya 1598 maka yang ter-set hanya 1598

[admin@MikroTik] > int ether set ether3 mtu=9000
[admin@MikroTik] > int eth pr
Flags: X - disabled, R - running, S - slave
 #    NAME                                                          MTU MAC-ADDRESS       ARP     
 0 R  ether1                                                       1500 00:24:81:05:A8:F5 enabled 
 1 R  ether2                                                       1500 68:05:CA:01:E3:61 enabled 
 2 R  ether3                                                       9000 68:05:CA:01:E3:60 enabled 

Contoh konfigurasi pada mikrotik






Related Posts:

Reset Cisco n3500 Nexus


Next

- Restart switch nexus
- Masuk boot dengan Ctrl + ]
- Config

switch(boot)# conf t

switch(boot)(config)# admin-password Admin123

switch(boot)(config)# exit

switch(boot)#dir bootflash:
switch(boot)# .
switch(boot)# ..
switch(boot)# xxxx.kickstart.xxxx.bin
switch(boot)# xxxxx.xxxxxx.xxxx.bin

switch(boot)# load xxxx.xxxxx.xxxx.bin

Setelah itu switch merestart kembali
login menggunakan:
user: admin
pass: Admin123

Pastikan ketika set switch(boot)(config)# admin-password Admin123 <--- password harus ada huruf besar salah satu, ini penting

kalau sudah login, baru set user baru dan set ip management

switch# conf t
switch(config)# username admin password Jakarta123
switch(config)# int mgmt 0
switch(config-interface)# ip address 192.168.5.155 255.255.255.128
switch(config-interface)# exit
switch(config)# ip route 0.0.0.0 0.0.0.0 192.168.5.129
switch(config)# exit
switch# copy running-config startup-config
switch# reload

Login biasa
Lalu sudah bisa diremote menggunakan vlan management ke ip 192.168.5.155



Related Posts: