Router & DHCP-Server in Mikrotik via Virtualbox

Oprek-oprek lagi, tes di vmware ane gak begitu ngerti dimana settingan interface bridge seperti yang ada di virtualbox...

Akhir nya setting di virtualbox... Komposisi:
1. Komputer Guest (Router Mikrotik)
2. Komputer Host (Laptop luar os Windows)

Sebenar nya bisa menggunakan 1 laptop, tp kebetulan isi virtualbox ane gak ada windows vm nya.. Jadi buat test dhcp-server nya jalan atau enggak, menggunakan laptop sebelah ane XD

Topology:


Jadi prosedur nya:
- Router Mikrotik mendapatkan internet dari wlan1
- Router Mikrotik memberikan DHCP melalui lan1
- Router Mikrotik me-masquearade jaringan di bawah nya agar dapat terkoneksi internet
- Komputer Windows mendapatkan internet & ip address dari Router Mikrotik

Aksi taraaaaaa...

- Pastikan router mendapatkan ip dari wlan1 / berikan ip nya
ip dhcp-client add interface=ether1 disabled=no
ip address print

- Kalau sudah dapat ip address nya pastikan konek internet
ping www.google.com
ping 8.8.8.8

- Kalau tidak dapat ip, berarti harus kasih ip static
ip address add address=192.168.0.100/24 interface=ether1

- Setelah itu baru setting dhcp server nya, jangan lupa setting ip address untuk eth2 sebagai interface yang memberikan ip dhcp
ip address add address=10.10.10.1/24 interface=ether2
ip dhcp-server
[admin@MikroTik] ip dhcp-server> setup
Select interface to run DHCP server on

dhcp server interface: ether2
Select network for DHCP addresses

dhcp address space: 10.10.10.0/24
Select gateway for given network

gateway for dhcp network: 10.10.10.1
Select pool of ip addresses given out by DHCP server

addresses to give out: 10.10.10.0.2-10.10.10.254
Select DNS servers

dns servers: 8.8.8.8
Select lease time

lease time: 3d
Ref: http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server

- Setelah itu setting nat nya
/ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
Ref: http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT

Taraaa selesai XD

Tinggal cek deh, komputer windows sebelah dapet ip address 10.10.10.x gk ? terus bisa internet gk ?
Harus nya bisa :p


Related Posts:

IIX a.k.a Indonesia Internet Exchange

Jalur Internet tanpa IIX

Jalur Internet dengan IIX

Apa itu IIX ?
  • Indonesia Internet Exchange (IIX) merupakan tempat terhubungnya berbagai ISP (Internet Service Provider), penyedia layanan internet di Indonesia, sebut saja 3G-Net, CBN, Indosat M2, Telkomnet Instant, dan lain-lain. Berdasarkan arti kata “Exchange” berarti pertukaran sedangkan “Internet” adalah kependekan dariInterconnection Networking. Dengan adanya IIX sambungan internet yang ada di Indonesia tidak harus berputar-putar melalui jalur yang ada di luar negeri dulu, baru kembali lagi ke Indonesia. Konsep penggabungan jalur berbagai ISP ke dalam suatu wadah dalam satu negara yang ada di Indonesia ini, merupakan yang pertama kali di dunia.
Pembentukan IIX
  • IIX dibentuk oleh APJII yang awalnya bersifat amal dan sukarela dengan maksud menyatukan lalu lintas antar ISP di Indonesia sehingga tidak perlu transit ke luar negeri. Tujuan IIX adalah membentuk jaringan interkoneksi nasional yang memiliki kemampuan dan fasilitas yang sesuai dengan kebutuhan yang ada, untuk digunakan oleh setiap ISP yang memiliki ijin beroperasi di Indonesia. ISP yang tersambung ke IIX tanpa biaya lebar pita, hanya biaya sambungan fisik sepeti serat optik, jalur nirkabel ataupun sewaan, yang berbeda-beda. Cukup murah bagi ISP yang berada di Jakarta tetapi mahal bagi ISP yang ada di luar Jakarta, apalagi di luar Jawa, karena biaya sambungan fisiknya saja jauh lebih mahal daripada sambungan internasional termasuk kapasitas lebar pita langsung melalui satelit ke luar negeri.
    IIX menjadi sebuah solusi atas keterbatasan infrastruktur isi dalam negeri yang seolah-olah terpisah dengan isi global. Dengan adanya IIX maka koneksi internet di Indonesia menjadi lebih murah. Indonesia Internet Exchange berkantor di Cyber Building 11th Floor, Jl. Kuningan Barat 8, Jakarta 12710
Apa tujuan didirikan IIX ?
  • Tujuan program IIX adalah membentuk jaringan interkoneksi nasional yang memilikai kemampuan dan fasilitas yang sesuai dengan kebutuhan yang ada, untuk digunakan oleh setiap Penyelenggara Jasa Internet yang memiliki ijin beroperasi di Indonesia.
    Pada saat ini program IIX tidak mempunyai tanggal berakhirnya program secara keseluruhan, melainkan dibagi atas tahapan-tahapan yang akan dikembangkan secara terus-menerus.
IIX lebih murah dari cost dan link lebih cepat karena tidak melewati hop terlallu banyak (tracert) dan bandwith jelas lebih besar dan lebih murah kalau kita taruh di luar negeri ga apa2 jika target client kita lebih banyak di luar bukan di indonesia tapi jika clients target dalam negeri jelas IIX pilihan terbaik dan tambahan untuk latency lebih kecil utk yg domestik, dan besar jika di taruh di luar jadi kesimpulan IIX lebih cepat hemat dan sekaligus nyumbang devisa dalam negeri dan lebih memperkaya alamat internet di indonesia.
Ibaratkan anda sekarang berada di Aceh. Lalu anda ingin menuju ke Jakarta. Ga harus transit dulu ke singapura kan? Selain faktor harga yang lebih murah, koneksi IIX ini juga bisa memperkaya konten internet di indonesia. Hal inipun bisa jadi pertimbangan anda dalam memilih hosting. Jika pengunjung situs anda kebanyakan dari dalam negri, ada baiknya anda memilih koneksi IIX ini meski konsekuensi yg diterima adalah kelambatan akses saat kita mengaksesnya dari luar negeri.

Ref: https://dhonconstantine.wordpress.com/2010/04/12/koneksi-iix/
Ref: http://www.iix.net.id/library/Iix_history.pdf

Related Posts:

Command Pocket Cisco XD


Ping, ARP, Mac Table
CDP Neighbor

ping 10.10.10.1
arp –a
arp –d

# show arp
# show iparp
# show mac-address-table
# show cdp neighboor
Static Routing
c# ip route 10.0.0.0 255.0.0.0 20.20.20.2
c# ip route 10.0.0.0 255.0.0.0 fa0/0

Show Command
RIP Routing
# show version
# show flash
# show running-config
# show startup-config
# show ip int br
# show interface
# show clock
# show history
# show ?
c# router rip
cr# network 10.0.0.0

c# router rip
cr# version 2
cr# network 10.0.0.0
OSPF Routing
c# router ospf 1
cr# network 10.10.10.0 0.0.0.255 area 0 cr# network 10.20.20.0 0.0.0.255 area 0
Password Config
c# enable password cisco
c# enable secret cisco

c# line console 0
cl# password cisco
cl# login

c# line vty  0 4
cl# password cisco
cl# login

c# service password-encryption

EIGRP Routing
c# router eigrp 10
cr# network 10.0.0.0

DHCP Server
c# ip dhcp pool LOCALNET
cd# network 10.0.0.0 255.0.0.0
cd# default-router 10.10.10.1
cd# dns-server 8.8.8.8
cd# ip dhcp excluded-address 10.10.10.2 10.10.10.10

c# int vlan 1
ci# ip address dhcp
ci# no sh
Information Config
c# banner motd “SWITCH XXX”
c# hostname RouterX

c# int fa0/0
ci# ip address 10.10.10.1 255.0.0.0
ci# description IP Public
ci# no shutdown

c# int vlan 1
ci# ip address 10.10.10.1 255.0.0.0
ci# description Room IT Dept
ci# no shutdown
PPP – CHAP
c# username R1 password cisco
c# int se2/0
ci# encapsulation ppp
c# ppp authentification chap

c# username R2 password cisco
ci# int se2/0
ci# encapsulation ppp
c# ppp authentification chap



Backup Config
c# copy flash tftp
c# copy run start
c# wr
c# copy start tftp
c# copy run tftp

# show flash
# sh run
# sh start


 VLAN Config
ACL Standard – Group & Telnet

c# vlan 2
cv# name HRD

c# int fa0/1
ci# switchport mode access
ci# switchport access vlan 2

# show vlan
# show vlan brief
c# access-list 1 permit 10.10.5.2 0.0.0.0
c# access-list 1 permit 10.10.5.3 0.0.0.0
c# access-list 1 deny any

c# line vty 0 4
cl# access-class 1 in

c# access-list 2 deny 20.0.0.2 0.0.0.0
c# access-list 2 permit any

c# int fa1/0
ci# ip access-group 2 out
Trunking & VTP Config
c# int fa1/0
ci# switchport encapsulation dot1q
ci# switchport mode trunk

c# vtp mode server
c# vtp domain ccna
c# vtp password

ACL Extended
c# access-list 101 deny tcp host 10.10.10.1 host 20.20.20.2 eq 80
c# access-list 101 deny ip host 10.10.10.1 host 20.20.20.2
access-list 101 permit ip any any

c# int fa0/0
c# ip access-group 101 out

c# ip access-list extended LAW
ca# deny ip host 10.10.10.1 host 20.20.20.1
ca# deny ip host 20.20.20.1 host 30.30.30.1
ca# permit ip any any

c# int fa0/0
ci# ip access-group LAW out
SPT & EC
c# no spanning-tree vlan 1

c# int range fa0/1-5
ci# channel-protocol lapc
ci# channel-group 1 mode active

c# interface port-channel 1
ci# switchport mode trunk
Serial Config
c# int se2/0
ci# clock rate 64000
ci# ip address 10.10.10.1 255.255.255.0
ci# no sh

# show controller se2/0 (DCE)
Frame Relay – MAP
c# se2/0
ci# encapsulation frame-relay
ci# clock rate 64000
ci# ip address 10.10.10.1
ci# frame-relay map ip 10.10.10.2 101 broadcast
ci# frame-relay lmi-type ansi
ci# no sh

c# se2/0
ci# encapsulation frame-relay
ci# clock rate 64000
ci# ip address 10.10.10.2
ci# frame-relay map ip 10.10.10.1 201 broadcast
ci# frame-relay lmi-type ansi
ci# no sh
HDCL Encapsulation
c# int se2/0
ci# encapsulation hdlc
ci# clock rate 64000
ci# no shutdown
PPP - PAP
c# username R1 password cisco
c# int se2/0
ci# encapsulation ppp
ci# ppp authentification pap
ci# ppp pap sent-username R2 password cisco

c# username R2 password cisco
c# int se2/0
ci# encapsulation ppp
ci# ppp authentification pap
ci# ppp pap sent-username R2 password cisco

Dont forget about clock rate
Frame Relay – Inverse
c# interface Serial2/0
ci# ip address 10.10.10.1 255.0.0.0
ci# encapsulation frame-relay
ci# frame-relay interface-dlci 101
ci# frame-relay interface-dlci 102
ci# clock rate 64000
Administrative Distance
-           RouterA sudah kenal 2 Router, masing-masing menggunakan 2 Protocol yang berbeda (RIP, OSPF) maka RouterA akan menggunakan Administrative Distance
-           RouterA sudah kenal 2 Router, masing-masing menggunakan 2 Protocol yang sama(EIGRP,EIGRP) maka RouterA akan menggunakan Cost Metric



Related Posts:

How To Check My DNS IP XD



What the ?   . . .


What the meaning ?  . . .

In front of my face is Panji, he was Engineer On Site in my temporery office... "Rawamangun"

How to check DNS ?


ipconfig /all
Kalau ini cuma buat ngecek dns ip di komputer kite...

nslookup
Ini juga sama, cuma di komputer kite, tapi lebih simpel...

ping ns1.domain.com
Kalau ini bisa juga cek aja ns1, ns2, ns3... dst... tergantung instansi nya make berapa ip dns...

tanya ke sys-admin nya...
Ini cara paling gampang... XD


Hahahahaa

Related Posts:

Install VNC Server On Ubuntu 14.04

Sekedar pengenalan, vnc server adalah aplikasi dari tightvnc untuk fitur remote via ssh (yang saya tau :D)
Jadi kalau di windows itu ada team viewer, remote desktop connection, atau ada juga tightvnc versi windows, nah di linux / ubuntu ini juga bisa diinstall team viewer / tighvnc, tapi saya lebih prefer vnc untuk lokal nya, karena tidak menggunakan internet. :)

Saya mengulang tutorial dari referensi ini:

https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-ubuntu-14-04

Langkah-langkahnya:

1. Install SSH Server terlebih dahulu
sudo apt-get install ssh

2. Update ubuntu
sudo apt-get update

3. Install tightvnc via apt
sudo apt-get install xfce4 xfce4-goodies tightvncserver

4. Jalankan VNC Servernya
vncserver

5. Masukkan password jika diminta, biasanya yang pertama itu password untuk remote, yang kedua itu password untuk mode view-only




Related Posts:

Recovery Password Switch Cisco



How to recovery cisco switch password ?

Sudah lama tidak berkutik di dunia cisco, pertama kali itu Januari 2015 an... terakhir kali Desember 2015 an hahahaha... Tahun 2016 pindah ke mikrotik semua XD keenakan di mikrotik hahaha....

Auto Winbox

Langsung aja buat catatan ringan saya saja...

1. Masuk CRT nya
2. Restart switch cisco nya
3. Tahan tombol mode beberapa detik sampai ada
flash_init
load_helper
boot
switch:
4. switch: flash_init
5. switch: load_helper
6. dir flash:
config.text itu config lama nya
7. rename flash:config.text flash:config.lama
8. boot (sampe sini dia reboot sementara)
9. klo ada pilihan yes/no pilih no "n"
10. sampe ada prompt Switch>
11. masuk enable
Switch> en
12. Switch# rename flash:config.lama flash:config.text
Destination filename [config.text] <---- enter
13. Switch# conf t
14. Switch(config)# enable secret password_baru_nya
15. Setting password vty
Switch(config)#line vty 0 15
Switch(config-line)#password password_baru_nya
Switch(config-line)#login

16. Setting password console sekalian
Switch(config-line)#line con 0
Switch(config-line)#password password_baru_nya

17. exit ke mode enable # terus write
Switch# write memory

Coba deh restart switch nya...

Cara ini buat switch, beda dengan router cisco... Lebih greget pake register 0xxxx hahaha

Semangat...

Related Posts:

Instalasi Graylog2 - OVA - Ubuntu Server

Tes tes tes...

1 . . . 2 . . . 3 . . .

Saya kembali lg dengan membawa berita baru, yaitu instalasi graylog2 (syslog) berbentuk OVA / untuk virtual machine menggunakan Ubuntu Server...
Ref: http://docs.graylog.org/en/2.1/pages/installation/virtual_machine_appliances.html


- Download Virtualbox & OVA Graylog2 nya
-- https://www.virtualbox.org/wiki/Downloads
-- https://packages.graylog2.org/appliances/ova
- Install virtualbox nya
- Masukin Ova Graylog2 nya
- Login ubuntu nya (kalau saya user: administrator, pass: graylog2)
- Masuk ke website dengan ip server nya dan port 9000 misal http://192.168.112.10:9000
- Login graylog2 nya (kalau saya user:admin, pass: password123)
- Setting-setting deh XD
- Jangan lupa di client side nya seperti di artikel sebelumnya http://muhammadnazaragliyono.blogspot.co.id/2016/09/sniffing-in-mikrotik-to-syslog-greylog.html


Troubleshoot:
- Mengecek ip address: ifconfig
- Mengecek port : netstat
- Merestart network: /etc/init.d/networking restart
- Merestart mongodb: /etc/init.d/mongodb restart
- Merestart graylog: /etx/init.d/graylog2-server restart
- Merestart grayweb: /etc/init.d/graylog2-web-interface restart
- Menjalankan service: ganti aja restart jadi start hahahaha...


Related Posts: